User Tools

Site Tools


en:orx:troubleshoot_building_orx

Troubleshoot Building Orx

This page is a random collection of tips for when you have difficulty building Orx.

.../memory/orxMemory.c:47:20: fatal error: malloc.c: No such file or directory

You need to run setup.sh / setup.bat to get the Orx dependencies.

This will occur if:

  1. You never ran setup before, or:
  2. You've done a git pull for the latest and forgot to run setup again for the latest dependencies.

The setup command should be automatic when first cloning. Try running ./setup.sh or setup.bat again.

Click to display ⇲

Click to hide ⇱

Hidden section

No output on mingw

For specific mingw issues, see the troubleshooter on this page.

C1900: Il mismatch in VS2015

>LINK : fatal error C1900: Il mismatch between 'P1' version '20150812' and 'P2' version '20130802'

If you get the above error in VS2015, it is because you need VS2015 Update 3. You can update under Tools / Extensions and Updates. Choose `Update 3`. This will download the installer to your machine. You'll need to close Visual Studio while you run the update.

Error running ./setup.sh

  ** Access Error: protocol error: "Timeout"

  ** Where: fail unless until sync-op either --anonymous-- read either either do catch either either --anonymous-- do trap if --anonymous--
  ** Near: fail make-http-error "Timeout" ??
  ** File: code/build/rebol/setup.r
  ** Line: 51''

or

** Access Error: protocol error: "Server closed connection" 
** Where: fail switch awake either switch switch --anonymous-- wake-up either until --anonymous-- wait until sync-op either --anonymous-- read either either do catch either either --anonymous-- do trap if --anonymous-- ** Near: _ fail error ?? 
** File: code/build/rebol/setup.r 
** Line: 51

Just some glitch out there in the matrix, like a network timeout. Just try ./setup.sh again.

/usr/bin/ld: cannot find -lsndfile

If you are building under Linux, you may possibly encounter this error while trying to compile

 /usr/bin/ld: cannot find -lsndfile

You require the libsndfile-devel package. For Fedora:

 yum install libsndfile-devel
 

Or in Debian or Ubuntu:

 apt install libsndfile1-dev

For more details on libraries required on Linux for Orx, see: Compiling the Orx library for Linux

en/orx/troubleshoot_building_orx.txt · Last modified: 2018/08/27 14:16 (3 months ago) by sausage